Repository navigation
Conversation
Resolves the high-severity advisory GHSA-86w9-cpqp-85rv (RSA PKCS#1 v1.5 signature verification accepts extra nested DigestAlgorithm elements), whose vulnerable range is <= 1.4.0. node-forge 1.4.1/1.4.2 (released 2026-10-27) are outside that range. Root declares node-forge ^1.3.3, so 1.4.2 satisfies; lockfile-only float, otel tree intact (1675/66).
Contributor
Author
|
Superseded by #4014 (merged 2026-10-29), which bumped @heroku/mcp-server to 1.2.13 and node-forge to 1.4.2 in one change — resolving the node-forge high (GHSA-86w9-cpqp-85rv) alongside the zod high. This standalone node-forge PR is no longer needed. Closing. |
This branch was successfully deployed
This file contains hidden or bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Sign up for free
to join this conversation on GitHub.
Already have an account?
Sign in to comment
Add this suggestion to a batch that can be applied as a single commit.This suggestion is invalid because no changes were made to the code.Suggestions cannot be applied while the pull request is closed.Suggestions cannot be applied while viewing a subset of changes.Only one suggestion per line can be applied in a batch.Add this suggestion to a batch that can be applied as a single commit.Applying suggestions on deleted lines is not supported.You must change the existing code in this line in order to create a valid suggestion.Outdated suggestions cannot be applied.This suggestion has been applied or marked resolved.Suggestions cannot be applied from pending reviews.Suggestions cannot be applied on multi-line comments.Suggestions cannot be applied while the pull request is queued to merge.Suggestion cannot be applied right now. Please check back later.
What
Bumps
node-forgefrom 1.4.0 → 1.4.2 (lockfile-only; root already declaresnode-forge ^1.3.3).Why
Resolves the open high-severity Dependabot alert #435 — GHSA-86w9-cpqp-85rv ("node-forge RSA PKCS#1 v1.5 signature verification accepts extra nested DigestAlgorithm elements").
The advisory's vulnerable range is
<= 1.4.0. node-forge 1.4.1/1.4.2 were released 2026-10-27, after the advisory was last refreshed (2026-10-01), so GitHub still listsfirst_patched_versionas none — but 1.4.2 is already outside the<= 1.4.0vulnerable range, so this clears the alert. Dependabot had not opened a PR because its advisory data predates the upstream fix.Scope
Single transitive copy (
node_modules/node-forge), floated vianpm update node-forge --package-lock-only.package.jsonis untouched and the@opentelemetrydependency tree is intact (1675 packages / 66 otel nodes — no dropped-node desync).Not included (tracked separately)
npmCLI (pulled in by@oclif/plugin-plugins → npm ^11.18.0). npm@12.2.1 (latest) still bundles undici 6.29.0 / ip-address 10.7.2, andoverridescan't reach bundled deps — blocked on npm upstream refreshing its bundle.@heroku/mcp-serverpins^3.25.76, so forcing it needs mcp-server compatibility testing — out of scope for a lockfile-only security fix.Testing
npm ciresolves the updated lockfile and the full test matrix passes)