Repository navigation
Conversation
Add the Python 3.14 classifier and a 3.14 job to the CI test matrix so the version metadata and CI agree. requires-python stays at >=3.12. Upgrade pydantic in uv.lock (2.11.7 to 2.14.1). The locked pydantic-core 2.33.2 has no Python 3.14 wheel and its pyo3 build cannot target 3.14, so the lock could not be installed on 3.14. This pulls in pydantic-core 2.50.1 and typing-extensions 4.16.0 as transitive updates. Also update the docs placeholder that lists supported Python versions. Refs #40
This file contains hidden or bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Sign up for free
to join this conversation on GitHub.
Already have an account?
Sign in to comment
Add this suggestion to a batch that can be applied as a single commit.This suggestion is invalid because no changes were made to the code.Suggestions cannot be applied while the pull request is closed.Suggestions cannot be applied while viewing a subset of changes.Only one suggestion per line can be applied in a batch.Add this suggestion to a batch that can be applied as a single commit.Applying suggestions on deleted lines is not supported.You must change the existing code in this line in order to create a valid suggestion.Outdated suggestions cannot be applied.This suggestion has been applied or marked resolved.Suggestions cannot be applied from pending reviews.Suggestions cannot be applied on multi-line comments.Suggestions cannot be applied while the pull request is queued to merge.Suggestion cannot be applied right now. Please check back later.
check-python-versionsreported a mismatch:requires-python = ">=3.12"allows any newer Python, while the classifiers and the CI test matrix stopped at 3.13. Python 3.14 was allowed to install but was never tested.This PR adds the Python 3.14 classifier and a 3.14 job to the test matrix, so the version metadata and CI agree.
requires-pythonstays open-ended, and the minimum version is unchanged.The locked
pydantic-core2.33.2 has no Python 3.14 wheel and cannot be built against 3.14, so the lock was upgraded withuv lock --upgrade-package pydantic(pydantic 2.11.7 to 2.14.1, withpydantic-core2.50.1 andtyping-extensions4.16.0 as transitive updates). The docs placeholder that lists the supported Python versions now names 3.12, 3.13 and 3.14. The docs build itself is unchanged:docs/Makefilestill caps Python below 3.14, and Read the Docs still pins 3.13.Closes #40